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Äàííàÿ ñòàòüÿ ïðåäâàðÿåò ñîáîé öèêë
ñòàòåé, ïîñâÿùåííûõ ñîçäàíèþ èíòåðàêòèâ-
íûõ àíèìàöèé ñ èñïîëüçîâàíèåì Flash-òåõ-
íîëîãèé, êîòîðûå â ïîñëåäíåå âðåìÿ ïîÿâè-
ëèñü ïî÷òè íà âñåõ êîìïüþòåðíûõ óñòðîé-
ñòâàõ. Ñàìûì ïðîñòûì èç ñåìåéñòâà ïàêå-
òîâ Flash è ñàìûì íåòðåáîâàòåëüíûì ê ñèñ-
òåìíûì ðåñóðñàì ÿâëÿåòñÿ Flash 4, ïîýòîìó
ðàññìîòðåíèå íà÷èíàåòñÿ èìåííî ñ íåãî.

ÂÂÅÄÅÍÈÅ

Ïðîãðàììíûé ïàêåò Macromedia Flash
(â äàëüíåéøåì ïðîñòî Flash) � ìîùíûé èíñò-
ðóìåíò, îáëåã÷àþùèé ñîçäàíèå àíè-
ìèðîâàííûõ WEB-ñòðàíè÷åê. Ìî-
äåëü ãðàôèêè â Flash ïðåäñòàâëÿåò
ñîáîé êîìáèíàöèþ ðàñòðîâîé è âåê-
òîðíîé ãðàôèêè, ñîåäèíÿÿ â ñåáå ïî-
ëîæèòåëüíûå ñòîðîíû îáîèõ ãðàôè-
÷åñêèõ ïðåäñòàâëåíèé.

Äëÿ òîãî ÷òîáû çàïóñòèòü
ïðîãðàììó Macromedia Flash, íåîá-
õîäèìî íàæàòü íà êíîïêó «Start»,
âûáðàòü «All Programs», íàéòè
ïóíêò Macromedia è â íåì íàéòè
Flash 4.

Äàâàéòå ïîçíàêîìèìñÿ ñ âíå-
øíèì âèäîì ãëàâíîãî îêíà è ðàñ-
ïîëîæåíèåì ïàíåëåé èíñòðóìåíòîâ
(ðèñóíîê 1).

Ñðàçó ïîä çàãîëîâêîì îêíà ðàñïîëî-
æåíî ìåíþ. Íèæå ìåíþ íàõîäèòñÿ ïàíåëü
êíîïîê, êîòîðûå äóáëèðóþò íàèáîëåå ÷àñòî
èñïîëüçóåìûå îïåðàöèè. Íèæå ïàíåëè êíî-
ïîê íàõîäèòñÿ îêíî óïðàâëåíèÿ ñëîÿìè
(Layers) è âðåìåííàÿ ëèíåéêà (Timeline). Â
öåíòðå ðàñïîëîæåíî ðàáî÷åå ïîëå � òî ìåñ-
òî, íà êîòîðîì áóäóò ñîçäàâàòüñÿ ðèñóíêè è
àíèìàöèÿ. Ñëåâà íàõîäèòñÿ ïàíåëü èíñòðó-
ìåíòîâ ðèñîâàíèÿ.

Ðàáîòó ñ ïàêåòîì íà÷íåì ñ íàñòðîéêè
ðàáî÷åé îáëàñòè. Äëÿ òîãî ÷òîáû íàñòðîèòü
ðàáî÷óþ îáëàñòü, íåîáõîäèìî âûáðàòü ïóíêò
ìåíþ Modify →→→→→ Movie.

Ðèñóíîê 1.
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Â îòêðûâøåìñÿ äèàëîãîâîì îêíå (ðè-
ñóíîê 2) âèäíû íàèáîëåå âàæíûå ïàðàìåòðû
ðàáî÷åé îáëàñòè: ðàçìåð ðàáî÷åé îáëàñòè â
ïèêñåëàõ (Dimensions), öâåò ôîíà (êíîïêà
Background) è êîëè÷åñòâî êàäðîâ â ñåêóíäó
(Frame Rate). Åäèíñòâåííûé ïóíêò, êîòîðûé
ñëåäóåò èçìåíèòü, ýòî Background � âûáðàòü
öâåò, áîëåå ïîäõîäÿùèé äëÿ âèçóàëüíîãî
âîñïðèÿòèÿ.

Äëÿ èçìåíåíèÿ öâåòà ôîíà íàäî íà-
æàòü íà êíîïêó ñ áåëûì êâàäðàòèêîì ðÿäîì
ñî ñëîâîì Background è âûáðàòü íóæíûé öâåò.

ÈÍÑÒÐÓÌÅÍÒÛ ÐÈÑÎÂÀÍÈß
(drawing tools)

Ðèñîâàòü âî Flash äîñòàòî÷íî ëåãêî,
åñëè Âû ïîéìåòå îñíîâíûå ïðèíöèïû, òà-
êèå, êàê èñïîëüçîâàíèå èíñòðóìåíòîâ, âû-
äåëåíèå, ñâÿçûâàíèå è ðàçáèåíèå.

Âûáåðèòå ðàçëè÷íûå èíñòðóìåíòû èç
ïàíåëè èíñòðóìåíòîâ ðèñîâàíèÿ. Â çàâèñè-

ìîñòè îò âûáðàííîãî èíñòðóìåíòà, âíåøíèé
âèä ïàíåëè ìîæåò èçìåíèòüñÿ, è ìîæåò ïî-
ÿâèòüñÿ âûïàäàþùåå ìåíþ â íèæíåé ÷àñòè
ïàíåëè. Ýòè èçìåíåíèÿ ïîêàçûâàþò, ÷òî
ìîæåò äåëàòü âûáðàííûé èíñòðóìåíò.

Èíñòðóìåíò ÑÒÐÅËÊÀ
Âûäåëÿåò, ìåíÿåò ôîðìó êðèâûõ è

ïåðåäâèãàåò ýëåìåíòû íà ðàáî÷åì ïîëå. Êðî-
ìå òîãî, ìîæåò èñïîëüçîâàòüñÿ äëÿ âûðåçà-
íèÿ ïðÿìîóãîëüíûõ îáëàñòåé ðèñóíêà. Êîã-
äà ñòðåëêà âûáðàíà, Âàì äîñòóïíû ñëåäóþ-
ùèå îïöèè:

Snap âêëþ÷àåò è âûêëþ÷àåò «íà-
ìàãíè÷èâàíèå». Èíñòðóìåíò «íà-

ìàãíè÷èâàíèå» ïîìîæåò âàì ðèñîâàòü, àâ-
òîìàòè÷åñêè âûðàâíèâàÿ ýëåìåíòû îòíî-
ñèòåëüíî äðóã äðóãà è ðàçìåòêè (grid) ñöå-
íû, òî åñòü ïîçâîëÿåò ïîçèöèîíèðîâàòü
îáúåêò ïî ëèíèÿì ñåòêè, òî÷íî ñîåäèíÿòü
êîíöû ëèíèé, ïîçèöèîíèðîâàòü öåíòð îä-
íîãî îáúåêòà ñ êîíöîì äðóãîãî è ò. ä.
Îí ðàáîòàåò òîëüêî ñî ñãðóïïèðîâàí-
íûìè ïðåäìåòàìè èëè ñ ñèìâîëàìè;

Smooth ñãëàæèâàåò âûäåëåííûå
êðèâûå;
Straighten âûïðÿìëÿåò âûäåëåí-
íóþ ëèíèþ (îòðåçîê ëèíèè) è
óìåíüøàåò êîëè÷åñòâî èçãèáîâ;
Rotate âðàùàåò è íàêëîíÿåò âûäå-
ëåííûé îáúåêò â ëþáîì íàïðàâëå-

íèè â ïëîñêîñòè ðèñóíêà;
Scale óâåëè÷èâàåò (óìåíüøàåò) âû-
äåëåííûé îáúåêò.

Ñòðåëêà ïîçâîëÿåò èçìåíÿòü ëèíèþ,
îòãèáàòü êðàÿ, èçìåíÿòü ôîðìó ôèãóðû, ïå-
ðåìåùàòü îáúåêòû, âûäåëÿòü ýëåìåíòû íå-
ñãðóïïèðîâàííûõ îáúåêòîâ, ðàçäåëÿòü íå-
ñãðóïïèðîâàííûå îáúåêòû íà ñîñòàâëÿþùèå
ýëåìåíòû. Äëÿ ïåðåìåùåíèÿ ýëåìåíòîâ èõ
íàäî âûäåëèòü. Åñëè Âû ïîïûòàåòåñü ïåðå-
äâèíóòü íåâûäåëåííóþ ëèíèþ, Âû èçìåíè-
òå åå ôîðìó, íî íå ñìîæåòå åå ïåðåäâèíóòü.
Åñëè âûäåëåíî íåñêîëüêî ïðåäìåòîâ, à Âàì
íóæíî ïåðåäâèíóòü òîëüêî îäèí, ñíèìèòå âû-
äåëåíèå è âûäåëèòå òîëüêî òîò îáúåêò, êî-
òîðûé Âàì íóæíî ïåðåäâèíóòü.

Åñëè Âû ïåðåäâèãàåòå âûäåëåííóþ çà-
ëèâêó ïîâåðõ äðóãîé çàëèâêè, òî òà ÷àñòü
ðèñóíêà, êîòîðàÿ íàõîäèòñÿ ïîä âåðõíåé çà-

Â öåíòðå ðàñïîëîæåíî ðàáî÷åå ïîëå, òî ìåñòî, íà
êîòîðîì áóäóò ñîçäàâàòüñÿ ðèñóíêè è àíèìàöèÿ.

Ðèñóíîê 2.
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ëèâêîé, âûðåæåòñÿ. Ýòî ñîâïàäàåò ñ òðàäè-
öèîííûìè ïðîãðàììàìè ðèñîâàíèÿ.

Èíñòðóìåíò ËÀÑÑÎ
Èíñòðóìåíò ËÀÑÑÎ âûäåëÿåò ïðî-

èçâîëüíóþ ÷àñòü ðèñóíêà. Ïîýòîìó ïðè ïî-
ìîùè ëàññî ìîæíî âûäåëÿòü áîëåå òî÷íî,
÷åì ïðè ïîìîùè ëþáîãî äðóãîãî èíñòðóìåí-
òà. ×òîáû âûäåëèòü îáëàñòü, âåäèòå ëàññî
âîêðóã ýòîé îáëàñòè. Çàêîí÷èòå êðóã ïðè-
áëèçèòåëüíî â òîì æå ìåñòå, ãäå íà÷àëè. Flash
àâòîìàòè÷åñêè çàêðîåò ïåòëþ ïðÿìîé.

Îáû÷íî òåêóùåå âûäåëåíèå ñíèìàåò-
ñÿ, êàê òîëüêî Âû äåëàåòå äðóãîå âûäåëåíèå,
íî åñëè Âû áóäåòå äåðæàòü íàæàòîé êëàâè-
øó Shift, êîãäà èñïîëüçóåòå ëàññî, Âû ñìî-
æåòå äîáàâëÿòü äðóãèå îáëàñòè ê óæå âûäå-
ëåííîé. Èñïîëüçóéòå âîëøåáíóþ ïàëî÷êó äëÿ
ëàññî, ÷òîáû âûäåëèòü êàêîé-ëèáî öâåò ó ðà-
ñòðîâîãî èçîáðàæåíèÿ, èìïîðòèðîâàííîãî âî
ôëýø (ïðåäâàðèòåëüíî îáÿçàòåëüíî ñäåëàé-
òå Modify → Break apart).

Äâà âûøåïåðå÷èñëåííûõ èíñòðóìåí-
òà òàêæå ÷àñòî èñïîëüçóþòñÿ äëÿ îïåðàöèé
âûðåçàíèÿ, êîïèðîâàíèÿ è âñòàâêè ôðàãìåí-
òîâ èçîáðàæåíèé. Ñîîòâåòñòâóþùèå êîìàí-
äû Edit → Cut, Edit → Copy è Edit → Paste.

Èíñòðóìåíò ËÈÍÈß
Ïîçâîëÿåò ðèñîâàòü ïðÿìûå ëèíèè.

Äîïîëíèòåëüíûå îïöèè:
� èçìåíåíèå öâåòà ëèíèè,
� èçìåíåíèå òîëùèíû ëèíèè,
� èçìåíåíèå ñòèëÿ ëèíèè (îäíî èç

ñòàíäàðòíûõ èëè Custom äëÿ ñîçäàíèÿ ñîá-
ñòâåííîãî ñòèëÿ).

Èíñòðóìåíò ÒÅÊÑÒ
Ïîçâîëÿåò ââîäèòü òåêñò àíàëîãè÷-

íî ëþáîìó òåêñòîâîìó ðåäàêòîðó. Ñîçäàåò
ïîëå ââîäà, êóäà ìîæíî ââîäèòü òåêñò.

Äîïîëíèòåëüíûå îïöèè ïîçâîëÿþò
èçìåíÿòü øðèôò è åãî ðàçìåð, âûäåëÿòü
æèðíûì èëè êóðñèâîì, âûðàâíèâàòü ïî öåí-
òðó, ñïðàâà, ñëåâà è ïî øèðèíå ñòðàíèöû.

Èíñòðóìåíòû ÊÐÓÃ è ÊÂÀÄÐÀÒ
Ïîçâîëÿþò ðèñîâàòü îâàëû è ïðÿ-

ìîóãîëüíèêè. Ïðè íàæàòîé êëàâèøå
Shift, ñîîòâåòñòâåííî, êðóãè è êâàäðà-

òû. Èíñòðóìåíò àíàëîãè÷åí èíñòðóìåíòó ËÈ-
ÍÈß, â äîïîëíèòåëüíûõ îïöèÿõ ìîæíî èç-

ìåíÿòü öâåò, òîëùèíó è ñòèëü êîíòóðà ôè-
ãóðû, à òàêæå öâåò çàëèâêè.

Èíñòðóìåíòû ÊÀÐÀÍÄÀØ è ÊÈ-
ÑÒÎ×ÊÀ

Èñïîëüçóéòå ÊÀÐÀÍÄÀØ è ÊÈ-
ÑÒÎ×ÊÓ, ÷òîáû ñîçäàòü ïðîèçâîëü-

íóþ  ëèíèþ èëè øòðèõ. Ëèíèÿ ÿâëÿåòñÿ
îäèíàðíûì ýëåìåíòîì. Øòðèõ êèñòî÷êè �
ýòî çàïîëíåííàÿ îáëàñòü ñ êîíòóðîì.

Êîãäà Âû ðèñóåòå ëèíèè, Flash ìîæåò
ñãëàæèâàòü êðèâûå, ïðåâðàùàòü èõ â èçëî-
ìàííûå ëèíèè èëè îñòàâëÿòü èõ â òî÷íîñòè
òàêèìè, êàê Âû íàðèñîâàëè. Âû âûáèðàåòå
ýòè îïöèè, èñïîëüçóÿ âûïàäàþùåå ìåíþ.
Ïîìèìî ýòîãî, Âû ìîæåòå óêàçàòü òîëùèíó,
ñòèëü è öâåò ëèíèè.

Straighten (âûïðÿìëåíèå) ðàñïîçíàåò
ëèíèè è êðèâûå è «âûïðÿìëÿåò» èõ. Òî åñòü,
åñëè Âû âûáåðåòå ýòó îïöèþ è íàðèñóåòå âîë-
íèñòóþ ëèíèþ, òî, êàê òîëüêî Âû îòïóñòèòå
ìûøü, ëèíèÿ ïðåâðàòèòñÿ â çèãçàãîîáðàçíóþ.

Èíñòðóìåíò ËÀÑÑÎ
âûäåëÿåò ïðîèçâîëüíóþ ÷àñòü ðèñóíêà.

Èíñòðóìåíò ÒÅÊÑÒ ïîçâîëÿåò ââîäèòü
òåêñò àíàëîãè÷íî ëþáîìó òåêñòîâîìó
ðåäàêòîðó.
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Smooth (ñãëàæèâàíèå) íå âûïðÿìëÿåò
ëèíèè è íå ðàñïîçíàåò êðèâûå. Òî åñòü, åñëè
Âû âûáåðåòå ýòó îïöèþ è íàðèñóåòå çèãçà-
ãîîáðàçíóþ ëèíèþ, îíà áóäåò âîëíîîáðàç-
íîé (òî åñòü ñãëàæåííîé).

Ink (÷åðíèëà) îñòàâëÿåò ëèíèè òàêè-
ìè, êàê Âû èõ íàðèñîâàëè, íå ñãëàæèâàÿ è
íå âûïðÿìëÿÿ.

Oval ðèñóåò îâàëû èëè êðóãè. Âåäèòå
ìûøüþ ïî äèàãîíàëè èç íà÷àëüíîé òî÷êè ê
êîíå÷íîé. Åñëè íàæàò «ìàãíèò», òî, êàê
òîëüêî ó Âàñ ïîëó÷àåòñÿ êðóã, êðóæî÷åê îêîëî
êóðñîðà ñòàíîâèòñÿ òåìíåå è áîëüøå.

Rectangle ðèñóåò êâàäðàòû è ïðÿìîó-
ãîëüíèêè. Ïðè íàæàòîì «ìàãíèòå», êàê òîëü-
êî ó Âàñ ïîëó÷àåòñÿ êâàäðàò, êðóæîê îêîëî
êóðñîðà ñòàíîâèòñÿ áîëüøå è òåìíåå.

Line ðèñóåò ïðÿìóþ ëèíèþ èç íà÷àëü-
íîé òî÷êè ê êîíå÷íîé. Ïðè íàæàòîì ìàãíè-
òå Âû ìîæåòå ïîëó÷èòü ãîðèçîíòàëüíóþ èëè
âåðòèêàëüíóþ ëèíèè, åñëè îòïóñòèòå ìûøü,
êàê òîëüêî îêîëî êóðñîðà ïîÿâèòñÿ áîëåå
òåìíûé è áîëüøîé êðóæîê.

Äîïîëíèòåëüíûå îïöèè êèñòî÷êè:
� ðèñóåò òàì, ãäå ðèñóåò,
� ïîêàçûâàåò êîíòóðû, êîòîðûå ïåðå-

ñåêàåò ìàçîê,
� ìàçîê îñòàâëÿåò çà ðèñóíêîì (âèäåí

òîëüêî íà ÷èñòîì ïîëå),
� ðèñóåò ìàçêè îò íà÷àëà ìàçêà äî ïåð-

âîãî êîíòóðà.

Èíñòðóìåíò ×ÅÐÍÈËÜÍÈÖÀ
×ÅÐÍÈËÜÍÈÖÀ ìåíÿåò öâåò, òîë-

ùèíó è ñòèëü íàðèñîâàííîé ëèíèè. Íàðè-
ñóéòå ëèíèþ. Ùåëêíèòå íà ÷åðíèëüíèöó è
âûáåðèòå äðóãîé öâåò, ñòèëü è ò. ä. Ùåëê-
íèòå íà íàðèñîâàííóþ ëèíèþ. Îíà ïîìå-
íÿåò ñâîè àòðèáóòû. Åñëè Âû âûäåëèòå íå-
ñêîëüêî ëèíèé è ùåëêíèòå ÷åðíèëüíèöåé
íà íèõ, òî âñå âûäåëåííûå ëèíèè ïîìåíÿ-
þò àòðèáóòû.

Áîëüøèíñòâî îïöèé ÷åðíèëüíèöû òà-
êèå æå, êàê è îïöèè êàðàíäàøà.

×åðíèëüíèöà íå èçìåíÿåò ëèíèé â
ñãðóïïèðîâàííîì ñèìâîëå.

Èíñòðóìåíò ÂÅÄÅÐÊÎ ÇÀËÈÂ-
ÊÈ

Çàëèâàåò êîíòóð âûáðàííûì öâåòîì.

Èíñòðóìåíò ÏÈÏÅÒÊÀ
ÏÈÏÅÒÊÀ áåðåò èíôîðìàöèþ î

öâåòå è ñòèëå ãîòîâîãî èçîáðàæåíèÿ. Êîãäà
Âû ùåëêàåòå íà îáëàñòü èíñòðóìåíòîì «ïè-
ïåòêà», îíà «êîïèðóåò» öâåò è ñòèëü. Åñëè
Âû ùåëêíåòå íà îáëàñòü çàëèâêè, îêîëî
ïèïåòêè ïîÿâëÿåòñÿ çíà÷îê êèñòî÷êè, åñëè
ùåëêíèòå íà ëèíèþ � ïîÿâëÿåòñÿ êàðàíäàø.
Èíñòðóìåíò «ïèïåòêà» î÷åíü ïîëåçåí äëÿ èç-
ìåíåíèÿ àòðèáóòîâ ëèíèè.

Çíà÷åíèÿ èíñòðóìåíòîâ «êàðàíäàø» è
«âåäåðêî çàëèâêè» ïðè ùåë÷êå ïèïåòêè ìå-
íÿþòñÿ íà òîò öâåò è ñòèëü, êîòîðûå «ñêî-
ïèðîâàëà» ïèïåòêà.

Åñëè Âû íàæìåòå Shift è ùåëêíåòå
ïèïåòêîé, öâåò, êîòîðûé îíà «ñêîïèðóåò»,
îäíîâðåìåííî ïîÿâèòñÿ è â èíñòðóìåíòå
«êàðàíäàø», è â èíñòðóìåíòå «âåäåðêî çà-
ëèâêè», è â èíñòðóìåíòå «òåêñò».

Ïðèìå÷àíèå: ïèïåòêà íå ìîæåò ñêî-
ïèðîâàòü èíôîðìàöèþ èç ñîäåðæèìîãî ñãðóï-
ïèðîâàííûõ ñèìâîëîâ, ïîêà Âû íå ñäåëàåòå
modify → break apart.

Èíñòðóìåíò ËÀÑÒÈÊ
ËÀÑÒÈÊ ñòèðàåò ëèíèè è çàëèâ-

êó. Âû ìîæåòå çàäàòü îïöèè ëàñòèêó òàê,
÷òî îí áóäåò ñòèðàòü òîëüêî ëèíèè, òîëüêî
çàëèâêó, òîëüêî âûäåëåííóþ çàëèâêó èëè
òîëüêî òó çàëèâêó, êîòîðóþ Âû íà÷àëè ñòè-
ðàòü. Èñïîëüçóéòå îïöèè ëàñòèêà, ÷òîáû
âûáðàòü îäèí èç ïÿòè ðàçìåðîâ èëè èçìå-
íèòü ôîðìó ëàñòèêà.

Ïðèìå÷àíèå: ëàñòèê ìîæåò ñòèðàòü ëè-
íèè è çàëèâêè òîëüêî â ñöåíå, îí íå ñòèðàåò
ãðóïïû îáúåêòîâ, ñèìâîëû èëè òåêñò. Åñëè
Âàì íóæíî ñòåðåòü ÷àñòü ãðóïïû, âûäåëèòå
ýòó ãðóïïó è âûáåðèòå Edit → Edit Selected
èëè Modify → Break Apart.

Îïöèè â âûïàäàþùåì ìåíþ îïðåäå-
ëÿþò, êàê ëàñòèê áóäåò ñòèðàòü. Îïöèè î÷åíü
ïîõîæè íà òå, êîòîðûå Âû âèäåëè â èíñòðó-
ìåíòå «êèñòî÷êà»:

Erase Fills ñòèðàåò òîëüêî çàëèâêó. Åñëè
Âû ïîïàäàåòå íà ëèíèè � îíè îñòàþòñÿ.

Erase Lines ñòèðàåò òîëüêî ëèíèè. Ïðè
ïîïàäàíèè íà çàëèâêó îíà îñòàåòñÿ íåòðîíóòîé.

Erase Selected Fills ñòèðàåò òîëüêî
âûäåëåííóþ çàëèâêó è íå çàòðàãèâàåò ëèíèè,
âíå çàâèñèìîñòè, âûäåëåíû îíè èëè íåò.
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Erase Inside ñòèðàåò òîëüêî òó îáëàñòü
çàëèâêè, ñ êîòîðîé Âû íà÷àëè ñòèðàòü (åñëè
Âû íà÷àëè ñòèðàòü ñ ïóñòîãî ìåñòà, ëàñòèê
íå ñîòðåò íè÷åãî). Ëèíèè â ýòîé îïöèè íå
çàòðàãèâàþòñÿ.

Èçìåíåíèå ðàçìåðîâ è ôîðìû ëàñòè-
êà ïîçâîëÿåò âûáðàòü ëþáîé èç 5 ðàçìåðîâ
ëàñòèêà è ôîðìó êðóãà èëè êâàäðàòà

Âîäîïðîâîäíûé êðàí
Óíè÷òîæàåò îòðåçîê ëèíèè èëè îá-

ëàñòü çàëèâêè. Ùåëêíèòå íà ëàñòèê, à
ïîòîì íà êðàí. Åñëè Âû ùåëêíåòå çàòåì íà
ëèíèþ èëè çàëèâêó, âñå îòðåçêè ëèíèè è
çàëèâêè áóäóò ñòåðòû.

Èíñòðóìåíò ÐÓÊÀ
Äâèãàåò âñå ðàáî÷åå ïîëå (çàìåíÿ-

åò ïîëîñû ïðîêðóòêè)

Èíñòðóìåíò ËÓÏÀ
Èçìåíåíèå ìàñøòàáà èçîáðàæåíèÿ.

Ïðèìå÷àíèå: Óâåëè÷åíèå è
óìåíüøåíèå íå ñîâïàäàþò ïî âåëè÷èíå
(îøèáêà ïðîãðàììû).

ÑËÎÈ

Ñëîè (Layers) èñïîëüçóþòñÿ äëÿ îáëåã-
÷åíèÿ ïðîöåññà ðåäàêòèðîâàíèÿ (ðèñó-
íîê 3). Ôàêòè÷åñêè ñëîè ïðåäñòàâëÿþò ñî-
áîé íàáîð ñòåêîë, íà êîòîðûõ íàðèñîâàíû
ôðàãìåíòû êàðòèíû. Íàëîæåííûå äðóã íà
äðóãà, îíè îáðàçóþò âñþ êàðòèíó. Êðîìå òîãî,
ðàçíûå òèïû àíèìàöèè ðåêîìåíäóåòñÿ ðàñ-
ïîëàãàòü íà ðàçíûõ ñëîÿõ.

Æåëàòåëüíî òàêæå èñïîëüçîâàòü îò-
äåëüíûé ñëîé äëÿ êíîïîê è êîìàíä.

Íà ïàíåëè óïðàâëåíèÿ ñëîåâ äîñòóï-
íû ñëåäóþùèå óñòàíîâêè ðåæèìîâ:

Ãëàç �Âèäíî/íå âèäíî èçîáðàæåíèå
íà ýòîì ñëîå;

Çàìîê � Çàïðåò/ðàçðåøåíèå ðåäàê-
òèðîâàíèÿ íà ýòîì ñëîå;

Êîíòóð � Ïðåäñòàâëåíèå îáúåêòîâ â
âèäå êîíòóðîâ. Î÷åíü ïîìîãàåò ïðè ðàáî-
òå ñ íåâèäèìûìè îáúåêòàìè (ïðîçðà÷íûå
îáúåêòû).

Ðåæèìû âêëþ÷àþòñÿ/âûêëþ÷àþòñÿ íà-
æàòèåì ëåâîé êíîïêè ìûøè íà ñîîòâåò-
ñòâóþùóþ èêîíêó.

ÂÈÄÛ ÀÍÈÌÀÖÈÈ

Îñíîâíîé ýëåìåíò, ñ ïîìîùüþ êîòî-
ðîãî ñîçäàåòñÿ àíèìàöèÿ � âðåìåííàÿ ëèíåé-
êà (Time line) (ðèñóíîê 4). Â îòëè÷èå îò ìóëü-
òèïëèêàöèè, ïðè êîòîðîé ïðèõîäèòñÿ ðèñî-
âàòü âñå êàäðû, îòðàæàþùèå ïðîöåññ èçìå-
íåíèÿ èëè äâèæåíèÿ, Flash ïîçâîëÿåò ðèñî-
âàòü òîëüêî êëþ÷åâûå êàäðû (Keyframe), à
èçîáðàæåíèå â êàäðàõ, íàõîäÿùèõñÿ ìåæäó
êëþ÷åâûìè, âûïîëíÿåòñÿ ïðîãðàììíî, ÷òî,
åñòåñòâåííî, îáëåã÷àåò ðàáîòó.

Àíèìàöèÿ âî Flash ïðåäñòàâëåíà äâó-
ìÿ âèäàìè: àíèìàöèÿ òèïà
Shape è àíèìàöèÿ òèïà
Motion. Ïðèíöèïèàëüíîå îò-
ëè÷èå ìåæäó ýòèìè òèïàìè
àíèìàöèè ñîñòîèò â òîì, ÷òî
ïåðâûé òèï ðàáîòàåò ñ ãðà-
ôèêîé êàê ñ íàáîðîì ãðàôè-
÷åñêèõ ïðèìèòèâîâ (ëèíèé,
äóã, îêðóæíîñòåé, ïðÿìîó-
ãîëüíèêîâ, çàëèâîê è ò. ä.),
à âòîðîé òèï ðàáîòàåò òîëü-
êî ñî ñãðóïïèðîâàííûìè
îáúåêòàìè, «ñèìâîëàìè»
(Symbols) â òåðìèíàõ Flash.

Èíñòðóìåíò ÐÓÊÀ

               Ðèñóíîê 3.             Ðèñóíîê 4.
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SHAPE

Shape (ïðåîáðàçîâàíèå ôîðìû, ìîð-
ôèíã) � èçìåíÿåò öâåò è ôîðìó.

Äàâàéòå àíèìèðóåì ïðåîáðàçîâàíèå
êâàäðàòà â êðóã.

Äëÿ ýòîãî:
1. Íàðèñóéòå êâàäðàò (âîñïîëüçîâàâ-

øèñü èíñòðóìåíòîì «êâàäðàò»). Öâåò ïðî-
èçâîëüíûé. Ðàçìåðû íàðèñîâàííîãî êâàäðà-
òà îñîáîé ðîëè íå èãðàþò, ãëàâíîå, ÷òîáû
îí âïèñûâàëñÿ â ðàçìåðû ðàáî÷åé îáëàñòè.
Îáðàòèòå âíèìàíèå íà ïàíåëü Timeline. Â
ïåðâîì êëþ÷åâîì êàäðå íà ïåðâîì ñëîå ïîñ-
ëå ðèñîâàíèÿ êâàäðàòà ïîÿâèëàñü ÷åðíàÿ òî÷-
êà. Ýòî îçíà÷àåò, ÷òî ïåðâûé êëþ÷åâîé êàäð
ñîçäàí.

2. Ñîçäàéòå êîíå÷íûé êëþ÷åâîé êàäð.
Äëÿ ýòîãî ïåðåâåäèòå êóðñîð, ê ïðèìåðó, íà
20 (ðèñóíîê 5), ùåëêíèòå íà êàäðå ëåâîé
êíîïêîé ìûøè è âûáåðèòå ïóíêò ìåíþ
Insert → Keyframe (F6).

3. Çàòåì (êóðñîð íàõîäèòñÿ íà êîíå÷-
íîì ôðåéìå), èñïîëüçóÿ èíñòðóìåíò «ñòðåë-
êà», âûãíèòå ñòîðîíû êâàäðàòà íàðóæó òàê,
÷òîáû êâàäðàò ñòàë ïîõîæ íà êðóã. Ìîæíî
âîîáùå ñòåðåòü êâàäðàò è íàðèñîâàòü êðóã
íà åãî ìåñòå. Ïðåæäå ÷åì ìåíÿòü ôîðìó ïðÿ-
ìîóãîëüíèêà, íåîáõîäèìî ñíÿòü ñ íåãî âû-
äåëåíèå (âèäíî â âèäå ïîëóïðîçðà÷íîé ñåò-
êè ïîâåðõ ïðÿìîóãîëüíèêà). Âûáåðèòå èí-
ñòðóìåíò «ñòðåëêà» è ùåëêíèòå ëåâîé êëà-
âèøåé ìûøè íà ôîíå ðàáî÷åé îáëàñòè (ðà-
áî÷óþ îáëàñòü ïðèíÿòî  íàçûâàòü ñöåíîé �
Scene).

4. Ùåëêíèòå ïðàâîé êíîïêîé ìûøè
íà ïåðâîì êàäðå è âûáåðèòå èç êîíòåêñòíî-
ãî ìåíþ ïóíêò Properties.

5. Âûáåðèòå çàêëàäêó  Tweening, èç
âûïàäàþùåãî ìåíþ âûáåðèòå Shape
tweening. (Îïöèÿ Distributive ëó÷øå ïîäõî-
äèò äëÿ êðóãëûõ ðèñóíêîâ. Angular � ëó÷øå
ïðèìåíÿòü äëÿ ðèñóíêîâ ñ ìíîæåñòâîì óã-
ëîâ, èçãèáîâ è ò. ä.)

6. Íàæìèòå êíîïêó OK (ðèñóíîê 6).
Îáëàñòü ìåæäó ïåðâûì è ïîñëåäíèì

êàäðîì çàêðàøèâàåòñÿ çåëåíîâàòûì öâåòîì,
è ïîÿâëÿåòñÿ ñïëîøíàÿ ñòðåëêà îò ïåðâîãî

êàäðà àíèìàöèè äî
ïîñëåäíåãî.

Äëÿ òîãî ÷òî-
áû ïðîâåðèòü ðå-
çóëüòàòû íàøåé
àíèìàöèè, âûáåðè-
òå ïóíêò ìåíþ
Contro l → Plaó
äëÿ îäíîêðàòíîãî

Ðèñóíîê 5.

... ïåðâûé òèï ðàáîòàåò ñ ãðàôèêîé êàê ñ
íàáîðîì ãðàôè÷åñêèõ ïðèìèòèâîâ ...,
à âòîðîé ... òîëüêî ñî ñãðóïïèðîâàííûìè
îáúåêòàìè, «ñèìâîëàìè» ...

Ðèñóíîê 6.
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ïðîèãðûâàíèÿ àíèìàöèè èëè ïóíêò ìåíþ
Control → Test movie � äëÿ ìíîãîêðàòíîãî.

Â êà÷åñòâå âòîðîãî ïðèìåðà íàðèñóåì
ýëëèïñ ñ ïåðåìåùàþùèìñÿ öåíòðîì ãðàäè-
åíòíîé çàëèâêè (ãðàäèåíòíàÿ çàëèâêà � çà-
ëèâêà, ñîñòîÿùàÿ èç äâóõ èëè áîëåå öâåòîâ,
ïëàâíî ïåðåõîäÿùèõ îäèí â äðóãîé.)

1. Íàðèñóéòå ýëëèïñ (âîñïîëüçîâàâ-
øèñü èíñòðóìåíòîì «êðóã»). Çàêðàñüòå ýë-
ëèïñ ãðàäèåíòíîé çàëèâêîé (îáÿçàòåëüíî
ðàäèàëüíîé) òàê, ÷òîáû åå öåíòð íàõîäèëñÿ
ó ëåâîãî êðàÿ ýëëèïñà (ðèñóíîê 7).

2. Ñîçäàéòå êëþ÷åâîé êàäð â 20 êàäðå
(âûäåëèòå ëåâîé êíîïêîé ìûøè è âûáåðèòå
ïóíêò ìåíþ Insert → Keyframe (F6)).

3. Çàêðàñüòå ýëëèïñ òåì æå öâåòîì,
íî òàê, ÷òîáû öåíòð çàëèâêè îêàçàëñÿ ó ëå-
âîãî êðàÿ (ðèñóíîê 8).

4. Ñîçäàéòå åùå îäèí êëþ÷åâîé êàäð â
40 ïîçèöèè. Ñíîâà ïîêðàñüòå ýëëèïñ òàê,
÷òîáû îí âûãëÿäåë òàê æå, êàê è â ïåðâîì
êàäðå.

5. Ùåëêíèòå ïðàâîé êíîïêîé ìûøè
íà ïåðâîì êàäðå è âûáåðèòå èç êîíòåê-
ñòíîãî ìåíþ ïóíêò Properties.

6. Âûáåðèòå çàêëàäêó Tweening,
èç âûïàäàþùåãî ìåíþ âûáåðèòå Shape
tweening.

7. Íàæìèòå êíîïêó OK.
8. Ïîâòîðèòå ïóíêòû 5�7 äëÿ 20

êàäðà.
Ïðîòåñòèðóéòå ïîëó÷åííóþ àíè-

ìàöèþ. Ó Âàñ äîëæíî ïîëó÷èòüñÿ öèê-
ëè÷åñêîå ïåðåìåùåíèå öåíòðà çàëèâêè
îò ëåâîãî êðàÿ ýëëèïñà ê ïðàâîìó è
îáðàòíî.

Â êà÷åñòâå äîïîëíèòåëüíîãî çàäàíèÿ
ñîçäàéòå ñîáñòâåííóþ ãðàäèåíòíóþ çàëèâêó
è ïîïðîáóéòå ïîâòîðèòü ïðåäûäóùåå çàäà-
íèå, çàëèâàÿ ýëëèïñ íå ñòàíäàðòíûì, à ñîá-
ñòâåííûì ãðàäèåíòîì.

Äëÿ ñîçäàíèÿ ñîáñòâåííîãî ãðàäèåíòà
âûáåðèòå èíñòðóìåíò «âåäåðêî», íà äîïîë-
íèòåëüíîé ïàíåëè èíñòðóìåíòîâ ùåëêíèòå
íà êíîïêå, ïîêàçûâàþùåé òåêóùèé öâåò. Â
îòêðûâøåéñÿ ïàíåëè âûáîðà öâåòà íàæìèòå
íà êíîïêó ñ èçîáðàæåííîé íà íåé ïàëèòðîé.
Îòêðûâàåòñÿ îêíî ðåäàêòèðîâàíèÿ öâåòà.
Ïåðåêëþ÷èòåñü íà ðåäàêòèðîâàíèå ãðàäèåí-
òîâ, âûáðàâ çàêëàäêó Gradient (ðèñóíîê 9).

Äëÿ òîãî ÷òîáû äîáàâèòü ñâîé öâåò,
íåîáõîäèìî ùåëêíóòü ëåâîé êíîïêîé ìûøè
(ËÊÌ) ÷óòü íèæå ïîëîñû, çàäàþùåé ãðàäè-
åíò, è äàëåå â ñïåêòðå âûáðàòü íóæíûé öâåò.
Ïîñëå ýòîãî ïîä ïîëîñîé ãðàäèåíòà ïîÿâëÿ-
åòñÿ íîâûé ïîëçóíîê, ïðè ïîìîùè êîòîðîãî
ìîæíî âàðüèðîâàòü ïåðåõîäû ìåæäó öâåòà-
ìè âíóòðè îäíîãî ãðàäèåíòà. Óñòàíîâèòå ðà-

Ðèñóíîê 7.

Ðèñóíîê 8.

 Íàðèñóéòå ýëëèïñ
(âîñïîëüçîâàâøèñü èíñòðóìåíòîì «êðóã»).

Ðèñóíîê 9.
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äèàëüíûé òèï ãðàäèåíòà, âûáðàâ èç ñïèñêà
ñòðî÷êó Radial. Íàæìèòå êíîïêó New, ÷òî-
áû äîáàâèòü íîâûé öâåò. Çàêðîéòå îêíî ðå-
äàêòîðà öâåòà.

Òåïåðü íåîáõîäèìî çàëèòü ïîëó÷åí-
íûì öâåòîì ýëëèïñ, èñïîëüçóÿ  èíñòðóìåíò
Paint Bucket � «âåäåðêî».

SHAPE HINTS

Â íåêîòîðûõ ñëó÷àÿõ àíèìàöèîííûå
àëãîðèòìû íå äàþò íåîáõîäèìîãî êà÷åñòâà
àíèìàöèè. Âèçóàëüíî ýòî âûðàæàåòñÿ â òîì,
÷òî èñõîäíûé îáúåêò «âûâîðà÷èâàåòñÿ íà
èçíàíêó» è òîëüêî ïîòîì ïðåâðàùàåòñÿ â
ðåçóëüòèðóþùèé. Äëÿ ïðåîäîëåíèÿ ýòîãî
ýôôåêòà èñïîëüçóåòñÿ ïðèåì Shape Hints èëè
«ìîðôèíã ñ ïîäñêàçêàìè». Ïîäñêàçêà (hint)

ïðåäñòàâëÿåò ñîáîé ìåòêó, êîòîðîé ïîìå-
÷àþòñÿ ñîîòâåòñòâóþùèå òî÷êè íà èñõîä-
íîì è ðåçóëüòèðóþùåì ðèñóíêàõ. Èõ èñ-
ïîëüçîâàíèå ïîçâîëÿåò íàïðàâèòü ïðîöåññ
àíèìàöèè íóæíûì îáðàçîì, äåëàÿ àíèìà-
öèþ áîëåå ýñòåòè÷íîé.

Â êà÷åñòâå ïðèìåðà äàâàéòå ïîïðî-
áóåì àíèìèðîâàòü ïðåâðàùåíèå öèôðû 1
â öèôðó 2.

Äëÿ ýòîãî:
1. Âêëþ÷èòå èíñòðóìåíò «òåêñò», óñ-

òàíîâèòå ðàçìåð øðèôòà 100 ïóíêòîâ, ïî-
ñòàâüòå íà ñöåíå öèôðó 1 (ðèñóíîê 10).

2. Ñîçäàéòå â 20 ïîçèöèè êëþ÷åâîé
êàäð.

3. Çàìåíèòå â 20 êàäðå öèôðó 1 íà
öèôðó 2.

4. Ðàçãðóïïèðóéòå îáå öèôðû, ïåðåé-
äÿ â ñîîòâåñòâóþùèé êàäð è âûïîëíèâ êî-
ìàíäó ìåíþ Modify →→→→→ Break Apart.

5. Ñîçäàéòå àíèìàöèþ Shape, âûïîë-
íèâ ïóíêòû 5�7 èç ïðåäûäóùåãî óïðàæíåíèÿ.

Ïðîâåðüòå ðåçóëüòàòû àíèìàöèè. Êàê
âèäèì, åäèíèöà âûâîðà÷èâàåòñÿ è ïðåâðà-
ùàåòñÿ â äâîéêó. Äëÿ ïðèäàíèÿ ýòîìó ïðî-
öåññó áîëüøåé ýñòåòè÷íîñòè âîñïîëüçóåìñÿ
ïîäñêàçêàìè.

6. Ðàçìåñòèòå äâå ïîäñêàçêè íà öèô-
ðå 1, äâàæäû âûïîëíèâ êîìàíäó ìåíþ
Modify →→→→→ Transform →→→→→ Add shape hint.

Ó Âàñ äîëæíû ïîÿâèòüñÿ äâà êðàñíûõ
êðóæêà ñ áóêâàìè a è b (êðóæêè íà-
êëàäûâàþòñÿ äðóã íà äðóãà, ïîýòîìó
âèäåí òîëüêî âåðõíèé) (ðèñóíîê 11).

Ìûøêîé ïåðåìåñòèòå ýòè êðóæ-
êè íà âåðõíèå óãëû «åäèíèöû» (ñì.
ðèñóíîê 11) è ïîâòîðèòå ýòó îïåðàöèþ
íà «äâîéêå». Êðóæêè äîëæíû ïîìåíÿòü
öâåò è ñòàòü æåëòûìè íà ïåðâîì êàäðå
è çåëåíûìè íà ïîñëåäíåì.

7. Ïðîòåñòèðóéòå ïîëó÷åííóþ
àíèìàöèþ.

Ðèñóíîê 10. Ðèñóíîê 11.

...èñõîäíûé îáúåêò
«âûâîðà÷èâàåòñÿ íà èçíàíêó»...
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MOTION

Ýòîò âèä àíèìàöèè ñîçäàåòñÿ òî÷íî
òàêèì æå îáðàçîì, êàê è ïðåäûäóùèé. Åäèí-
ñòâåííîå îòëè÷èå çàêëþ÷àåòñÿ â òîì, ÷òî
ïîñëå ñîçäàíèÿ ðèñóíêà åãî íåîáõîäèìî ïðå-
îáðàçîâàòü â îáúåêò (symbol â òåðìèíàõ
Flash). Ñèìâîëû, êàê óæå áûëî ñêàçàíî âûøå,
ïðåäñòàâëÿþò ñîáîé íàáîð ãðàôè÷åñêèõ ïðè-
ìèòèâîâ, îáúåäèíåííûõ â åäèíûé îáúåêò. Â
ïàêåòå Flash ñèìâîëû ìîãóò áûòü òðåõ òèïîâ:

Graphics � ïðîñòîå îáúåäèíåíèå ïðè-
ìèòèâîâ.

Button � îáúåêò, âûïîëíÿþùèé ôóí-
êöèè êíîïêè, òî åñòü ïîçâîëÿþùèé âûïîë-
íèòü îïðåäåëåííûå äåéñòâèÿ ïðè ùåë÷êå
êóðñîðîì ìûøè íà íåì.

Movie Clip � àíèìàöèîííûé ðîëèê.
Ñèìâîëû ìîãóò áûòü ïîìåùåíû â áèá-

ëèîòåêó è çàòåì èñïîëüçîâàòüñÿ ìíîãîêðàò-
íî ïî ìåðå íàäîáíîñòè.

Ñèìâîë ìîæåò áûòü ñîçäàí äâóìÿ
ñïîñîáàìè:

1) Ñ ïîìîùüþ ìåíþ Insert →→→→→ New
symbol... ñîçäàåòñÿ íîâûé (ïóñòîé) ñèìâîë,
â êîòîðîì ïðîèçâîäèòñÿ ðèñîâàíèå. Ïðè ýòîì
â äèàëîãîâîì îêíå íàäî âûáðàòü òèï ñîçäà-
âàåìîãî ñèìâîëà è åãî èìÿ (èìÿ ïî óìîë÷à-
íèþ Symbol ¹ ...) Ïîñëå îêîí÷àíèÿ ðèñîâà-
íèÿ ñèìâîë ïåðåíîñèòñÿ â ëîêàëüíóþ áèá-
ëèîòåêó ñèìâîëîâ.

2) Âûäåëèòü «ñòðåëêîé» îáëàñòü ðèñóí-
êà, èç êîòîðîãî Âû õîòèòå ñîçäàòü ñèìâîë.
Âûáåðèòå ïóíêò ìåíþ Insert →→→→→ Convert to
Symbol... è íàæìèòå êíîïêó OK (íå çàáóäü-
òå óêàçàòü òèï ñèìâîëà). Ñîçäàííûé ñèì-
âîë áóäåò ïîìåùåí â áèáëèîòåêó, äîñòóï-
íóþ ñ ïîìîùüþ êîìàíä Window → Library,
è îñòàíåòñÿ íà ðàáî÷åì ïîëå.

Îïåðàöèÿ, îáðàòíàÿ ñîçäàíèþ ñèìâî-
ëà, òî åñòü ðàçáèâàþùàÿ ñèìâîë íà ñîñòàâ-
ëÿþùèå åãî ïðèìèòèâû, âûïîëíÿåòñÿ âûáî-
ðîì ïóíêòà ìåíþ Modify →→→→→ Break Apart.
Äàëüíåéøèé ïðîöåññ ñîçäàíèÿ àíèìàöèè
íè÷åì íå îòëè÷àåòñÿ îò ñîçäàíèÿ Shape. Íà
ïîñëåäíåì øàãå íàäî óñòàíîâèòü íå Shape
Twinning, a Motion Tweening. Ñóùåñòâóåò
áîëåå êîðîòêèé ñïîñîá ñîçäàíèÿ ýòîé àíè-
ìàöèè: íàäî ùåëêíóòü ïðàâîé êíîïêîé ìûøè
ìåæäó êëþ÷åâûìè êàäðàìè è âûáðàòü ïóíêò
ìåíþ Create Motion Tween.

Â êà÷åñòâå ïðèìåðà äàâàéòå ñäåëàåì
ñëåäóþùåå: íàðèñóåì ïðÿìîóãîëüíèê è çàñ-
òàâèì åãî äâèãàòüñÿ èç ëåâîãî âåðõíåãî óãëà
ñöåíû â ïðàâûé íèæíèé, îäíîâðåìåííî ñòà-
íîâÿñü ïðîçðà÷íûì è âðàùàÿñü ïî ÷àñîâîé
ñòðåëêå.

Äëÿ ýòîãî:
1. Íàðèñóéòå ïðÿìîóãîëüíèê. Èíñò-

ðóìåíòîì «ñòðåëêà» âûäåëèòå ïðÿìîóãîëü-
íèê è ïðèìåíèâ ê íåìó êîìàíäû ìåíþ
Insert → Convert to symbol, ïðåîáðàçóéòå
Âàø ïðÿìîóãîëüíèê â ñèìâîë. Òèï ñèìâîëà
(Behavior) óñòàíîâèòå Graphic, âûáðàâ ñîîò-
âåòñòâóþùóþ êíîïêó (ðèñóíîê 12). Íàæìè-
òå ÎÊ, ïåðåäâèíüòå ïðÿìîóãîëüíèê â ëåâûé
âåðõíèé óãîë.

2. Ñäåëàéòå 20 êàäð êëþ÷åâûì. Ïåðå-
ìåñòèòå â íåì ïðÿìîóãîëüíèê â ïðàâûé íèæ-
íèé óãîë.

3. Ùåëêíèòå ïðàâîé êíîïêîé ìûøè
(ÏÊÌ) ìåæäó êëþ÷åâûìè êàäðàìè è âûáåðèòå
ïóíêò ìåíþ Create Motion Tween èç êîíòåêñò-
íîãî ìåíþ. Ïðÿìîóãîëüíèê äâèãàåòñÿ!

4. Äëÿ äîáàâëåíèÿ ýôôåêòà ïðîçðà÷-
íîñòè âûáåðèòå 20 êàäð (êëþ÷åâîé) è â íåì
ùåëêíèòå ÏÊÌ ïî ïðÿìîóãîëüíèêó. Èç êîí-

Îïåðàöèÿ,
îáðàòíàÿ ñîçäàíèþ ñèìâîëà,

òî åñòü ðàçáèâàþùàÿ ñèìâîë

Ðèñóíîê 12.
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òåêñòíîãî ìåíþ âûáåðèòå ïóíêò Properties,
ùåëêíèòå íà çàêëàäêå Color Effect. Èç ñïèñ-
êà ýôôåêòîâ âûáåðèòå Alpha. Â îêîøêå ââî-
äà çàìåíèòå öèôðó 100% íà 0%. Íàæìèòå
ÎÊ. Ñèìâîë ïðîïàë!!! (ðèñóíîê 13).

5. Äëÿ äîáàâëåíèÿ âðàùåíèÿ ùåëêíè-
òå ÏÊÌ íà ïåðâîì êàäðå íà âðåìåííîé ëè-
íåéêå. Èç êîíòåêñòíîãî ìåíþ âûáåðèòå ïóíêò
Properties. Îòêðîéòå çàêëàäêó Tweening (ðè-
ñóíîê 14).

Â îòêðûâøåìñÿ îêíå ïàðàìåòðîâ àíè-
ìàöèè Motion îòêðîéòå ñïèñîê íàïðîòèâ ïîëÿ
Rotate è âûáåðèòå Clockwise äëÿ âðàùåíèÿ

ïî ÷àñîâîé ñòðåëêå èëè CounterClockWise
äëÿ âðàùåíèÿ â îáðàòíóþ ñòîðîíó. Â îêîøêå
ââîäà times óñòàíîâèòå íóæíîå êîëè÷åñòâî
îáîðîòîâ (2). Íàæìèòå ÎÊ.

6. Çàäàíèå âûïîëíåíî. Ïðîâåðüòå ðå-
çóëüòàòû êîìàíäîé Control →→→→→ Test Movie.

MOTION GUIDE

Ýòî ðàñøèðåíèå àíèìàöèè òèïà
Motion. Ïîçâîëÿåò çàäàòü äâèæåíèå Âàøåãî
îáúåêòà ïî òðàåêòîðèè ëþáîé ôîðìû. Äëÿ
óïðîùåíèÿ ðàáîòû âîñïîëüçóåìñÿ ãîòîâûì
ñèìâîëîì èç áèáëèîòåêè Flash. Îòêðîéòå îêíî
áèáëèîòåêè êîìàíäîé Library →→→→→ MovieClips.

Èç ñïèñêà êëèïîâ âûáåðèòå Biplane
(ñàìîëåò), ùåëêíóâ íà åãî èçîáðàæåíèè
ËÊÌ. Íå îòïóñêàÿ êíîïêè, ïåðåòàùèòå ñèì-
âîë íà ñöåíó (ðèñóíîê 15). Èíñòðóìåíòîì
«ñòðåëêà» óìåíüøèòå ðàçìåðû ñàìîëåòà â äâà
ðàçà. Ñîçäàéòå êëþ÷åâîé êàäð â 25 êàäðå.

Íà ïàíåëè óïðàâëåíèÿ ñëîÿìè ùåëê-
íèòå íà ñèðåíåâîé èêîíêå ñ èçîáðàæåíèåì
ëîìàíîé ëèíèè (Add Guide Layer).

 Âûøå Âàøåãî ñëîÿ ñ ñàìîëåòîì
(Layer1) ðàçìåñòèòñÿ ñëîé ñ íàçâàíèåì Guide
Layer1. Ïåðåêëþ÷èâøèñü íà ýòîò ñëîé,
âîçüìèòå èíñòðóìåíò «êàðàíäàø» è íàðèñóé-
òå íà ñöåíå òðàåêòîðèþ ïîëåòà ñàìîëåòà. Â
íà÷àëüíîì êàäðå ñîåäèíèòå öåíòð îáúåêòà
(êðåñòèê) è íà÷àëî òðàåêòîðèè, â ïîñëåäíåì
� ñîåäèíèòå êðåñòèê ñ êîíöîì òðàåêòîðèè.
Äëÿ óïðîùåíèÿ ñîåäèíåíèÿ öåíòðà îáúåêòà
è òðàåêòîðèè ðåêîìåíäóåòñÿ âêëþ÷èòü ðå-
æèì «íàìàãíè÷èâàíèÿ» Snap. Âñòàâüòå àíè-
ìàöèþ Motion â ïåðâîì ñëîå (Layer1). Åñëè

Âû õîòèòå, ÷òîáû
îáúåêò ïðîñòî äâèãàë-
ñÿ ïî òðàåêòîðèè, òî
ùåëêíèòå ÏÊÌ íà
ïåðâîì êàäðå 1-ãî ñëîÿ,
âûáåðèòå Properties,

Ðèñóíîê 13.

Ðèñóíîê 14.

Ïîçâîëÿåò çàäàòü äâèæåíèå âàøåãî îáúåêòà
ïî òðàåêòîðèè ëþáîé ôîðìû.

Ðèñóíîê 15.
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îòêðîéòå çàêëàäêó Tweening è â îêîøêå
«orient to path direction» ôëàæîê óáåðèòå, à
åñëè õîòèòå, ÷òîáû îáúåêò èçìåíÿë ñâîþ
îðèåíòàöèþ â ïðîñòðàíñòâå â çàâèñèìîñòè
îò íàïðàâëåíèÿ òðàåêòîðèè, òî â îêîøêå
«orient to path direction» ïîñòàâüòå ôëàæîê
(ðèñóíîê 16).

ÏÓÁËÈÊÀÖÈß FLASH-ÐÎËÈÊÎÂ.

Äëÿ òîãî ÷òîáû îïóáëèêîâàòü ôàéëû ñ
öåëüþ äàëüíåéøåãî ðàçìåùåíèÿ â Internet,
íåîáõîäèìî ñîõðàíèòü ôàéë è âûïîëíèòü
âñåãî îäíó êîìàíäó File →→→→→ Publish. Ïðè âû-
ïîëíåíèè ýòîé îïåðàöèè â òîì æå êàòàëîãå,
ãäå Âû ñîõðàíÿëè Âàø Flash-ôàéë, ïîÿâèòñÿ
ôàéë, èìåþùèé òî æå èìÿ è ðàñøèðåíèå
SWF. Ýòîò ôàéë è èñïîëüçóåòñÿ äëÿ ïîìå-
ùåíèÿ íà âàøó ñòðàíè÷êó (íàïðèìåð, ñ ïî-
ìîùüþ ïðîãðàììû Dreamweaver).

ÑÎÇÄÀÍÈÅ ÂÛÕÎÄÍÎÃÎ ÔÀÉËÀ

Äëÿ òîãî ÷òîáû ñîçäàòü çàãðóçî÷íóþ
ñòðàíèöó, íà êîòîðîé áóäåò ðàçìåùåíà òîëüêî
Flash-àíèìàöèÿ, íåîáõîäèìî ïðîäåëàòü ñëå-
äóþùèå îïåðàöèè:

1. Ñîçäàòü ñ èñïîëüçîâàíèåì âûøå
ïîëó÷åííûõ çíàíèé àíèìàöèþ, íàïðèìåð,

àíèìàöèþ ãðàäèåíòíîé çàëèâêè, â êîòîðîé
áóäåò ïåðåëèâàòüñÿ íàäïèñü «Ìîé ñàéò».

2. Ùåëêíóòü ËÊÌ íà ïîñëåäíåì êëþ-
÷åâîì êàäðå àíèìàöèè, âûáðàòü ïóíêò ìåíþ
Properties è â îòêðûâøåìñÿ îêíå îòêðûòü
çàêëàäêó Actions.

3. Íàæàâ íà êíîïêó «+», âûáðàòü èç
ñïèñêà êîìàíä êîìàíäó Stop.

4. Ñíîâà íàæàòü íà êíîïêó «+» è âûá-
ðàòü èç ñïèñêà êîìàíä êîìàíäó GetURL. Â
ïðàâîå ïîëå ââîäà ââåñòè èìÿ ôàéëà  Âàøåé
òèòóëüíîé ñòðàíè÷êè (íàïðèìåð, index.htm)
(ðèñóíîê 17).

Îáÿçàòåëüíî ïðîâåðüòå, ÷òîáû Âàøà
ãëàâíàÿ ñòðàíèöà èìåëà èìÿ index.htm !!!

5. Äàëåå íåîáõîäèìî ñîõðàíèòü ôàéë
File →→→→→ Save â òó æå ïàïêó ïîä èìåíåì index.

Èòîãîâûé ôàéë ñîçäàí, åãî íåîáõîäè-
ìî òîëüêî îïóáëèêîâàòü.

... âûïîëíèòü âñåãî îäíó êîìàíäó
File →→→→→ Publish.

Øòåííèêîâ Äìèòðèé Ãåííàäèåâè÷,
Ñàíêò-Ïåòåðáóðãñêèé
Ãîñóäàðñòâåííûé Óíèâåðñèòåò
Èíôîðìàöèîííûõ Òåõíîëîãèé
Ìåõàíèêè è Îïòèêè.

Ðèñóíîê 16. Ðèñóíîê 17.


